Author Topic: 91 sierra ignition problem  (Read 53 times)

Offline Wayfarer

  • Regular Member
  • *
  • Posts: 11
  • Karma: 0
91 sierra ignition problem
« on: June 15, 2020, 05:10:24 PM »
Hi all, need some help/advice. Washed the zook by hand at car wash and wouldn't restart. Lifted bonnet and found everything dry. RACQ came and said no spark. Got towed home. I suspected coil so pulled out and checked. On the info I found it seemed ok. I checked leads, fuse and changed ignition module but still no spark. New coil is $290 so don't want to buy 1 until I'm sure that's the problem. Any ideas or coil info would be appreciated
Thanks

Offline James R

  • Club Member
  • Rock Crawler
  • ****
  • Posts: 1,055
  • Karma: 16
Re: 91 sierra ignition problem
« Reply #1 on: June 16, 2020, 10:07:03 AM »
I think I have a spare coil you can try. Iíll check tonight...
Jellybean - 1999 SWB Grand Vitara 1.6L
The Project - 1988 and a half SWB SJ50 soft top
The Highlander - 1987 lwb canopy

Offline DMAC

  • Cone Crusher
  • ***
  • Posts: 891
  • Karma: 0
  • Miss Daisy
Re: 91 sierra ignition problem
« Reply #2 on: June 18, 2020, 01:46:13 PM »

Stripped Cam gear - Happened once. Does the dizzy turn?

Just other option apart from the coil.

Offline Wayfarer

  • Regular Member
  • *
  • Posts: 11
  • Karma: 0
Re: 91 sierra ignition problem
« Reply #3 on: June 18, 2020, 05:50:33 PM »
Thanks James let me know if you got one.
That's one thing I haven't checked but will do thanks DMac

Offline James R

  • Club Member
  • Rock Crawler
  • ****
  • Posts: 1,055
  • Karma: 16
Re: 91 sierra ignition problem
« Reply #4 on: June 24, 2020, 08:59:52 AM »
Sorry mate, itís a dodgy old 1ltr one.
Jellybean - 1999 SWB Grand Vitara 1.6L
The Project - 1988 and a half SWB SJ50 soft top
The Highlander - 1987 lwb canopy